XWE tutorial

From SRB2 Wiki
(Redirected from XWE Tutorial)
Jump to: navigation, search

Welcome. This article is designed to help those who are not familiar with XWE. This article dives into the basic functions of XWE, and can teach you the basics of usage. Much of XWE's options only become important as you learn to create wads, and based on what kind of wads are created. This will not teach you all aspects of wadding. This will only teach you the basic options and menus. However, this is enough to get started on the basics of XWE.

Contents

Getting started

Installing

The first thing to do is to download XWE. The most recent version with features SRB2 needs can be found here. After downloading, just extract it to a folder. That's all there is to installing it.

Note that you must have administrative access for XWE to function properly.

XWE on Windows Vista or 7

If you are using either Windows Vista or 7, then you have to go through a short series of steps in order for the program to correctly run, otherwise it will result in errors and be unusable.

First, once you have downloaded the program, right click on the XWE .EXE file. This makes a dropdown menu appear. Click on "Run as Administrator", and a window will appear. Press the "Allow" button, and XWE should start correctly.

To eliminate the need for right-clicking each time you want to use the program, right-click the icon and click on "Properties". Go to the "Compatibility" tab, and and check the box labeled "Run this program as an administrator", then press "Ok". Now the window will appear each time you start the program without having to manually run it.

Setup

After extracting XWE into your folder, a simple setup is required. Once XWE is extracted, open the program. A little box should pop up. It should look a bit like this:

Xwe popupwindow1.png

Click on the "Browse" button. This should open up another box. It'll look like this:
Xwe popupwindow2.png

This window is used for determining where the IWAD is, so that XWE can run. Simply click the folder icon with the upwards facing arrow until it shows you your desktop. From there, open the folder where SRB2 was installed to. In the box with the text "File name:" is, type srb2.srb, and click the open button. (Note, do not put the comma after srb2.srb.). If done correctly, this will take you back to the first window that popped up. Click the Ok button, and you're all set to start using XWE!

Lowercase lumps and other menu options

You might want to use XWE for making character WADs for SRB2 and want to use lowercase lumps. We should also set up XWE so it doesn't clean up lumps when it exits. Why would we want to do that? It is because XWE will modify any wad you open. If you happen to open SRB2.srb, then it change it when you close it and then you wont be able to run SRB2 until you get the unmodified srb2.srb. You click on View → Options. In there you will see a bunch of check marks. In the General tab, make sure that the Perform clean up on exit is unchecked. Go to the Entry List tab then make sure the "Don't auto capitalize lump names" has a check mark.

Interface

File:Xwe gui 1.png


Map key

A) Menu options
B) Lump List
C) Display

Menu options

In order to use XWE correctly, you will need to familiarize yourself with its menu options. All the options play various roles in how you use XWE. So, let's get started.

File

The File menu is used for dealing with what wad file you're using, and maintaining it. It has a few options for doing this.

  • New: This option is used to create a whole new wad file. When this option is selected, a popup similar to the second one when you were setting up XWE appears. This pop up window is for determining where your wad file is saved to. It's best to save the wads into SRB2's folder, so you can use them when you're done editing them right away. Once you name the wad file, click the "Save" button, and XWE will allow you to start editing the wad. But we'll get into that later.
  • Open: This option is used for opening a wad that has already been made. When this option is selected, a box similar to the second one when you were setting up XWE appears. This pop up window is used for selecting the wad you wish to open. Browse for the location the wad file was saved to, and click the "Open" button. This opens the wad, and XWE will allow you to continue editing it. But we'll get into that later.
  • Merge: This is a more advanced option, used for joining two wads together. This option is only accessible when a wad file is loaded. When selected, a menu like the one that appeared when setting up XWE will appear. This menu is for selecting the other wad you wish to merge with the one XWE has open. In order to use this option, an external program must be installed. Without it, this option is useless with XWE. If there is an overwhelming need to use this, download it here.
  • Join (add lumps only): This is a more advanced option, used for adding lumps from another wad into a wad XWE has open. This option is only accessible if XWE has a wad loaded. When selected, a menu like the one that appeared when setting up XWE will appear. This menu is for selecting the other wad you wish to select additional lumps from. In order to use this option, an external program must be installed. Without it, this option is useless with XWE. If there is an overwhelming need to use this, download it here.
  • Close: Removes the wad XWE has open from its memory. Upon closing the wad, it is automatically saved. After closing the wad, XWE remains open, allowing for another wad file to be worked on.
  • Clean Up: Cleans up a wad XWE has loaded. The term "clean up" in this instance refers to deleting leftover data in the wad. When lumps are deleted (More on this later), they are no longer listed in the wad, but their memory is still in the wad, and makes the wad bigger. This option deletes the excess memory.
  • List Unused Textures: Lists textures the wad has within it, but is not used in any of the maps uses. (More on this later).
  • History: This is actually not so much an option. Instead, XWE lists the four most recently loaded wads here. If nothing has been loaded yet, this section does not appear. Selecting one of the recently opened wads loads it into XWE. Note that the only reason History is shown as the header was becaue there was no better way of conveying this section
  • Exit: Closes XWE and any wad file it might have loaded. On closing, XWE saves all changes to the wad that were made.

Edit

The Edit menu is, ironically, not used for editing the wad. At least not unless the wad has lumps. The options here are the generic Windows tool options.

  • Undo: Reverts an edit of something done previously. Note that not all changes can be undone.
  • Cut: Removes all selected lumps from the list, but allows you to paste them back into the wad.
  • Copy: Copies all selected lumps from the list, and allows you to paste them back in XWE. Copied lumps are still kept in XWE.
  • Paste: Pastes cut or copied lumps into XWE. Note that only lumps can be pasted into XWE, and only lumps cut or copied in the current XWE running can be pasted.
  • Empty Clipboard: Prevents cut or copied lumps from being pasted. It is advised not to use this option unless you're absolutely certain of what you're doing.

Entry

The Entry menu is where most wad design options are. Here, there are options that add, import, and export data.

  • New: Generates a new lump. The type of lump generated is called a marker.
  • Delete: Deletes all selected lumps.
  • Rename: Renames one highlighted lump entry.
  • View raw data: Views raw data (usually in Hex) for all lump entries. This option is useless for most kinds of wad editing.
  • Load: Loads a file that is selected from a popup dialog box. SRB2 only uses certain types of files, so it is advised to look through the Wiki, and figure out what kind of wad is being designed before a file is selected.
  • Load (raw data): Loads a file selected from a popup dialog box. Only, it loads the actual file as a whole, rather than converting it to something XWE recognizes. It is advised not to use this option unless you know exactly what you're doing.
  • Replace: Works similar to Load, except it replaces a selected lump, and keeps the previous lump's name.
  • Replace (raw data): Works similar to the Replace option, except it replaces a selected lump with a file's raw data. It is advised not to use this option unless you know exactly what you're doing.
  • Save: Saves a lump. Depending on the file that it is trying to save, XWE will make the file an image, music, or a lump file (.lmp). If saved as a lump file, renaming the extension to the appropriate file type will fix this.
  • Save (raw data): Works similar to the Save option, with the difference that it saves every file as a lump file. It is advised not to use this option unless you know exactly what you're doing.
  • Move Up: Moves all highlighted lumps up one space on the list.
  • Move Down: Moves all highlighted lumps down one space on the list.

Help

The Help menu brings up options designed to assist the user with whatever may be needed in XWE. Anything not covered in this tutorial can likely be found in here.

  • Contents: Brings up the actual help topics list along with a search function.
  • About: Brings up a small popup with information about the creators of XWE.

Final Note

There are many other buttons and options that XWE provides. However, those are for more advanced editing, and not needed for simple things. Learn more about these options through the tutorials provided here. Many are explained because they are needed to do specific kinds of things.

Lump list

The lump list displays the list of lumps in the currently open wad. For more information about lumps, go here.

Display

XWE displays an image, text, a map, and other things, depending on the lump selected. There are many kinds of lumps, so it can display many different things. This screen is used differently for different kinds of wads. It is advised to learn about the wad to be designed before using this screen.

Conclusion

This concludes the overview of XWE's most basic functions. Again, this will not teach you how to make wads. This will only teach XWE's most basic functions. However, the SRB2 Wiki has many tools & tutorials to continue on learning about wad editing. These are available to all and are recommended learning tools.

See also

Personal tools
Namespaces

Variants
Actions
Navigation
SRB2
Modification
Community
Toolbox