User talk:MarkGyver

From SRB2 Wiki
Jump to: navigation, search

If needed, discuss whatever here.

Cannot get it to work on Linux

After getting the source through SVN (svn co svn://code.srb2.org/SRB21094 ./srb2), changing to the right directory (cd ./srb2/trunk/src), and telling it to compile (make LINUX=1), I get the following output:

Creating dependency file, depend.dep
Created dependency file, depend.dep
g_game.c: In function ‘G_DoSaveGame’:
g_game.c:2534: warning: array subscript is above array bounds
console.c: In function ‘CONS_Clear_f’:
console.c:154: warning: the address of ‘con_buffer’ will always evaluate as ‘true’
y_inter.c: In function ‘Y_StartIntermission’:
y_inter.c:1212: warning: array subscript is above array bounds
y_inter.c:1316: warning: array subscript is above array bounds
y_inter.c:1320: warning: array subscript is above array bounds
y_inter.c:1322: warning: array subscript is above array bounds
hardware/hw_light.c:1093: warning: ‘HWR_ComputeLightMapsInBSPNode’ defined but not used
hardware/hw_main.c:3715: warning: ‘HWR_QuickSortPlane’ defined but not used
Linking lsdlsrb2...

After adding srb2.srb to the release folder, running the binary (../bin/Linux/Release/lsdlsrb2) results in the following:

Compiled for SDL version: 1.2.13
Linked with SDL version: 1.2.13
Setting up SRB2...
Looking for WADs in: SRB2WADDIR,.,/usr/local/games/srb2,/usr/games/srb2,HOME
 Oct 30 2008                   Sonic Robo Blast 2                      00:29:43
Sonic Robo Blast 2
Z_Init: Init zone memory allocation daemon.
system memory 3041MB free 567MB
48 megabytes requested for Z_Init.
W_Init: Init WADfiles.
I_StartupTimer...
File Li not found.
File Li not found.
File Li not found.
File Li not found.
File Li not found.
File Li not found.
File Li not found.
File Li not found.
File Li not found.
File Li not found.
File Li not found.
File Li not found.
Shutdown tty console
Error: W_InitMultipleFiles: no files found

Am I doing something wrong? I'm running fully up-to-date Arch Linux on a ThinkPad T61p laptop. Googling the "File Li not found." error (with quotes) didn't turn up any results and the only results from Googling "Error: W_InitMultipleFiles: no files found" are in a foreign language. Google's translation of the later error searchs result seems to indicate that it's not for an unrelated issue. MarkGyver 06:43, 30 October 2008 (UTC)

You said that only srb2.srb was copied, what about other files listed at http://trac.srb2.org/browser/SRB2109/src/d_main.c?rev=589#L873 LoganA 19:42, 31 October 2008 (UTC)
I actually copied all the files from the windows version, as extracted from the .exe on the site using Wine. MarkGyver 21:46, 31 October 2008 (UTC)
Well, I would ask you to try "make clean" and "make LINUX=1 ECHO=1", and and ask for Alam in the chatroom irc://irc.esper.net/srb2fun for help/ LoganA 02:25, 5 November 2008 (UTC)
"make clean" worked great! Thanks! Now the only issues seemto be that at least one video mode not a multiple of 320 x 200 don't work and that it suddenly crashed while I was typing this (not trying full screen yet), but IIRC, windowed mode has always been problematic on all platforms, so I can't really complain.